"Missing model definition!" causing crash

Post Reply
man_of_many_names
Posts: 8
Joined: December 23rd, 2018, 7:16 pm

"Missing model definition!" causing crash

Post by man_of_many_names » May 6th, 2019, 4:23 pm

Hi. Is there any way to remove model from map a different way ? I have some models in my map that cause editor to crash when they're loaded. This prevents me from deleting them just by pressing D and clicking on them. Or maybe is there anything else that can fix the crash ?

This is the error I get in game log:

Code: Select all

<ERROR> Missing model definition! (item: 0x2DAA4C5454400001)
User avatar
Arayas
Site Admin
Posts: 1437
Joined: December 15th, 2018, 3:25 am

Re: "Missing model definition!" causing crash

Post by Arayas » May 6th, 2019, 4:36 pm

delete "editor" folder in ......\mydocuments\ets2

that will reset the editor

once editor is loaded type in console "g_delete_uid 0x2DAA4C5454400001"
Editor of Romania Extended Map
support@roextended.ro
www.roextended.ro
man_of_many_names
Posts: 8
Joined: December 23rd, 2018, 7:16 pm

Re: "Missing model definition!" causing crash

Post by man_of_many_names » May 6th, 2019, 4:41 pm

Thank you. I'll try that.
man_of_many_names
Posts: 8
Joined: December 23rd, 2018, 7:16 pm

Re: "Missing model definition!" causing crash

Post by man_of_many_names » May 6th, 2019, 5:30 pm

It crashes when I use that command.
User avatar
Arayas
Site Admin
Posts: 1437
Joined: December 15th, 2018, 3:25 am

Re: "Missing model definition!" causing crash

Post by Arayas » May 6th, 2019, 5:45 pm

Then type GOTO 0x2DAA4C5454400001 see what is the problem and move the model in an unused sector.
Editor of Romania Extended Map
support@roextended.ro
www.roextended.ro
man_of_many_names
Posts: 8
Joined: December 23rd, 2018, 7:16 pm

Re: "Missing model definition!" causing crash

Post by man_of_many_names » May 6th, 2019, 5:49 pm

It won't let me see the model.
Post Reply