Using the Map Editor

Lereveur
Posts: 6
Joined: April 9th, 2023, 9:22 pm

Re: Using the Map Editor

Post by Lereveur » February 3rd, 2024, 8:56 am

Hello

Thank you very much, this is a perfect answer to my concern.

Eric
Pezehgehmer
PPM
Posts: 3
Joined: September 21st, 2023, 7:50 pm

Re: Using the Map Editor

Post by Pezehgehmer » February 7th, 2024, 9:36 pm

It was obviously not smart from me, but i used some "xmas"-objects in the editor. and now i got erros, because SCS seemed to removed them. it is not that much, 3 streets are missing and a few nice jeeps on parking lots. but the thing is, there are now little skull objects and i cannot delete them. any idea? Thanks!

Log:
00:00:29.724 : <ERROR> Unable to find 'road_mat.8_xmas' for 'Road' 0x517241D239800000
00:00:29.724 : <ERROR> Unable to find 'road_mat.8_xmas' for 'Road' 0x5182F59A17000000
00:00:29.724 : <ERROR> Unable to find 'road_mat.8_xmas' for 'Road' 0x5182FAD5C1000001
00:00:29.724 : <ERROR> Unable to find 'road_mat.8_xmas' for 'Road' 0x5182FDD34A000000
00:00:29.724 : <ERROR> Unable to find 'road_mat.8_xmas' for 'Road' 0x5183B380E4000001
00:00:29.724 : <ERROR> Unable to find 'road_mat.8_xmas' for 'Road' 0x5183D09961000000
00:00:29.724 : <ERROR> Unable to find 'road_mat.8_xmas' for 'Road' 0x518C52CD2E000001
00:00:29.724 : <ERROR> Unable to find 'road_mat.8_xmas' for 'Road' 0x518C915981800000
00:00:29.724 : <ERROR> Unable to find 'road_mat.8_xmas' for 'Road' 0x518D6DFB93800001
00:00:29.727 : Map base sectors successfully loaded.
00:00:29.727 : Map sectors loading started ....
00:00:29.728 : <ERROR> Unable to find 'model.xmas_4s002' for 'Model' 0x52548A1EA6800001
00:00:29.741 : <ERROR> Unable to find 'model.xmas_0700o' for 'Model' 0x52480ACC8A800001
00:00:29.741 : <ERROR> Unable to find 'model.xmas_0700o' for 'Model' 0x52480AD30C000001
00:00:29.741 : <ERROR> Unable to find 'model.xmas_0700o' for 'Model' 0x52480AD8AA000001
00:00:29.749 : <ERROR> [mover_item_t::post_load] Undefined mover model! (32114.128906;30.101563;71793.140625)


EDIT:
found a solution and i answer myself here in case somebody has the same issue:
Go to Debug/Validate Errors and then you can delete the errors with right click
User avatar
ItzHonzula
VIP
Posts: 448
Joined: October 22nd, 2020, 8:46 pm
Location: Reichenberg, Czech Republic

Re: Using the Map Editor

Post by ItzHonzula » February 9th, 2024, 10:35 pm

i'll never get why SCS decided to remove those assets, they were actuallly good and useful insome cases
EuRoadNet and Projekt Česko developer.

silly nonbinary existence :3
User avatar
FunTrucker_18
PPM
Posts: 721
Joined: December 15th, 2018, 3:16 pm
Location: Germany

Re: Using the Map Editor

Post by FunTrucker_18 » April 6th, 2024, 1:04 am

SCS Logic somtimes. "Oh, you find these assetes useful? Okay - Fuck them and fuck you, too!" :haha:
Image
User avatar
FunTrucker_18
PPM
Posts: 721
Joined: December 15th, 2018, 3:16 pm
Location: Germany

Re: Using the Map Editor

Post by FunTrucker_18 » April 9th, 2024, 2:33 am

After a long hiatus I've decided to come back to mapping as a "part time" job. While Project Caucasus is maintained by our Fixer-God Jerry and the map feels good with him, I wanted to keep "Road to Aral" fresh with minor adjustments to the updates because the dickwart I trusted the map with lost interested after just 1 small update. But I've ran into a hitch:

Guys, what is this, why are these roads missing? In the game itself they're there but in the editor the roads (and prefabs, signs etc.) are just gone. Do I need to replace them all or is there a trick to bring them back?

Imageets2_20240408_230552_00
Image
User avatar
Arayas
Site Admin
Posts: 7368
Joined: December 15th, 2018, 3:25 am
Location: Romania
Contact:

Re: Using the Map Editor

Post by Arayas » April 9th, 2024, 6:58 am

If a road has assigned to it some vegetation or terrain profile removed from the game/map, thats the result.
editor.log is your friend, there you will see all problems.
ImageImage Image
support@roextended.ro
www.roextended.ro
User avatar
FunTrucker_18
PPM
Posts: 721
Joined: December 15th, 2018, 3:16 pm
Location: Germany

Re: Using the Map Editor

Post by FunTrucker_18 » April 9th, 2024, 7:47 pm

Seems like SCS removed a LOT of things, at least 600 Prefabs are gone, the ones from FLD I managed to bring back, which will reduce my work time
Image
Post Reply